
 
 

CS 1033 
Multimedia and Communications 

 

 
Lab 10: Sound Editing with Audacity and 

Incorporating Sound, Animation and Video 
into a Webpage with KompoZer 

 
 

NOTE: you will need headphones for this lab 

to plug into the computer. In the labs, try 
doing the following if the front headphone 

jacks are not working: 
Start>Control Panel>Sound Effects 

Manager>Front Panel>Headphone for the 
jack where you plug in your headphones. 
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BEFORE YOU START – Configuring your headphones 

 
Since you will be working with audio this week, you will be bringing in a pair of 
headphones to plug into the front of your computer in the lab. Unfortunately, the 

lab computers don’t automatically “know” that your headphones were plugged in, 
so you will have to set the audio output to your headphones first! 

 
1. After you login to your computer, look to the bottom right of your screen for 

the System Tray. 
In it, you will see a blue icon with yellow lines (if you leave your mouse 

overtop of it, it will say “Sound Effect”). Double click it to open the 
speaker settings (see image below). 

 
 

 

2. The “Realtek Control Panel” will appear. Click on the tab marked “Speaker 
Configuration” at the top of the window (if it is not open already), which will 

switch to the window below: 

 
 
 

3. Near the in the bottom right corner, there is an area marked “Front Panel”.  

a. The red circle on your screen matches the red audio jack on the front of 
your computer, and is where a microphone would be plugged in. 
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b. The green circle on your screen matches the green audio jack on the 
front of your computer, and is where you plug your headphones in. 

Plug in your headphones here. 
 

4. Finally, in the dropdown beside the green circle on your screen, change the 
setting from “Not connected” to “Headphones”. Click the “X” at the top 

of the screen to save your settings and exit. Your headphones are now 
properly configured! 
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Reference Sheet – Audacity Layout 
 
Audacity is a free, powerful, and easy to use audio editor and recorder for 

Windows, Mac OS X, Gnu Linux, and other operating systems. The screenshot 
below highlights its layout - use it as a reference during this lab. 

 

 
 

Although Audacity is a very powerful audio editor that works with an unlimited 
number of tracks of virtually any size, it cannot do everything. It cannot: 

 record more than two channels at once on many systems, 

 edit MIDI files, although it can open them. 
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Lab 10 - Tutorial 1 
 
Objectives: 

 
Upon completion of tutorial 1, you should be able to: 

 Import a sound file into Audacity and listen to the sound using the play 

button. 

 Identify and explain the purpose of various buttons in the Audacity interface.  

 Select a portion of a sound clip and remove that portion from the clip 

 Amplify a selection of the audio clip 

 Fade out a selected portion of the audio clip 

 Convert an audio clip to a .WAV format or a .MP3 format 

 

COPYING AND EXTRACTING THE FILES NEEDED FOR LAB 10 

 
1. Download the file lab10.zip from 

http://www.csd.uwo.ca/~lreid/cs1033labs/lab10 (click on the lab10.zip file 
and save it) to F:\\c1033 (the cs1033 folder on your memory stick) 

2. Right click on the lab10.zip file and select Extract All... 
3. It should try to extract the files to a folder inside your cs1033 folder called 

lab10 (e.g. F:\cs1033\lab10). Click on the Extract Button 
4. There now should be a lab10 folder in your cs1033 folder that contains all the 

files and folders you will need for this lab. 
 

 
IMPORTING AND EDITING A SOUND CLIP 

 
5. Start the program by either clicking on the Audacity shortcut icon on the 

desktop OR click on the magnifying glass in the bottom left corner and search 

for the word “Audacity” 
6. Notice that the Selection Tool is selected by default (it appears to be pressed 

down). This tool is often called an “I Beam” because it looks like a capital I.  

 
7. Notice a series of round buttons which have controls similar to a CD Player.  

We will be using the Play and Stop buttons frequently. Other controls will be 
mentioned as needed.  

 

http://www.csd.uwo.ca/~lreid/cs1033labs/lab10
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8. From the Menu Bar, select File > Import > Audio. Browse to the lab10 
folder you copied to your memory stick and open the file bart.wav. If a 

screen pops up, select Make a copy of the files before editing (safer) and 
press OK. 

9. Save the file as an Audacity Project: from the Menu Bar, select File > Save 
Project As, and save the file in your lab10 folder as bart.aup 

10. Press the Play button  to play the sound file. 
11. To play the sound file starting at different spots on the sound wave, select 

the I-Beam   and click on any spot in the wave, then press the Play 

button again.  Notice how it begins to play starting from that point on. To 
return to the beginning, move the I-Beam to the beginning of the track.  

12. Replay the sound file again and try out the Audio buttons:  Stop, Pause, 
Skip to Start, and Skip to End. Notice the Skip to Start and Skip to End 

buttons only work when you hit the Stop button, not when you hit the Pause 
button 

 
13. We are going to remove the door closing sound near the end of the 

sound clip. Find the "door closing" sound. Play the sound a few times until 
you figure out where the door sound is in the wave pattern. The door sound is 

indicated by the red outline indicated in the diagram below: 

 
14. Click on the I Beam tool. Then put (Click) the cursor (the I Beam) at the 

beginning of the sound, hold down the left mouse button and select/highlight 

to the end of the wave representing the door closing sound. (Should look like 
image above). 

15. From the Menu Bar, select Edit > Delete to delete this section.  
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16. Now we will amplify (make louder) Bart’s excuse for missing the test, where 

he says “Ohhhh, my ovaries!” 
a. First, we need to select that portion of the sound clip using the I 

Beam/Selection Tool. Find that (“Ohhh, my ovaries”) area of the sound 
waves and highlight it.  

b. From the menu bar, select Effect>Amplify. Use the default amplify 
setting (4.3 dB) and press OK. Play the clip again to make sure it is 

louder. 
c. Select/Highlight the same area again (or 

leave it highlighted if it is still highlighted) 
and select Effect>Amplify and change 

the value to -15.0 and press OK. Play the 
clip and notice that this makes the clip 

quieter. 

d. The bigger (more than 0) the amplification 
number the louder the clip, the smaller 

(less than 0), the clip will get more quiet. 
17. Now you are going to fade out the las half of the 

“Ohhhhhh” exclamation as follows: 
a. Using the I Beam tool, select just the “Ohhhhh” sound (not the “my 

ovaries” part). 
b. From the menu, select Effect>Fade Out and hit OK 

 
c. Try playing the full sound clip and make sure the word “ohhhh” faded 

away but “my ovaries” was still audible.  
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CONVERTING AN EDITED SOUND CLIP TO UNIVERSAL SOUND FORMATS 

(.WAV AND .MP3) 
 

18. Now we are going to convert the newly edited sound clip to a WAV format (a 
well known format for audio files): 

a. Save your project again just to be on the safe side (as bart.aup) 
b. From the menu select File>Export Audio. 

c. Make sure the Save as type: is set to WAV and save it as 
bartnew.wav to your lab10 folder and hit the Save button.  You do 

not need to fill in the window asking for things like Artist Name, just 
press the OK button.  

19. Now we are going to convert the newly edited sound clip to a MP3 format 
(another well-known format for audio files). Normally MP3 files have much 

better compression (make for smaller file sizes) than WAV files.  

a. From the menu select File>Export Audio 
b. Make sure the Save as type: is set to MP3 Files and save it as 

bartnew2.mp3 
c. Hit the Save button 

d. Hit the OK button 
e. Audacity does not come with MP3 support by default, and you will see a 

message asking to Locate Lame. Click Browse and you should find the 
file lame_enc.dll in you lab10 folder on your memory stick.   

 
f. Note: If you plan to install Audacity at home, you must download the 

lame_enc.dll file. You can download it by clicking the Download button 

on this screen. 
20. Close Audacity, browse to your lab10 folder, notice the size difference in 

between the .wav file and the .mp3 file 
21. Test to see if your WAV and MP3 files play in Windows Media Player. If 

Media Player asks to install an additional codec, click Install. 
 



 9 

 

Lab 10 - Tutorial 2 
 

Objectives: 
 

Upon completion of tutorial 2, you should be able to: 
 Import a more than one sound clip and create sounds that overlap with other 

sounds. 

 Use the Time Shifting Tool to move clips to different sections of the sound file 

 Zoom in and out of the tracks. 

 Create an .mp3 file with tags associated with it such as Artist and Album 

Name.  

 
OVERLAPPING (MIXING) SOUNDS TOGETHER, CREATING A MULTI TRACK 

SOUND. 
 

1. Start up the Audacity program again by clicking on the icon on the desktop 

2. From the menu, select File > Import > Audio..., and select the file in the 
folder lab10 called beam1.mp3  (human voice) 

3. From the menu, select File > Import > Audio..., and select the file 
memento.mp3  (song) 

4. From the menu, select File>Save Project As and save your project in the 
lab10 folder as mixing.aup  Your screen should look like this: 

 
5. Press the Play button and listen to the first 20 seconds (both will play 

simultaneously). The first clip is 4 seconds long, while the second is over a 

minute. Note the beam1.mp3 file is in mono with only one sound wave, while 
memento.mp3 is in stereo with two (separate sound wave for left and right 

speakers). 
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6. To listen to each track separately, use the "Mute" button to temporarily de-
activate one track from playing. Experiment by setting the "Mute" for the first 

track and playing, then with the second. When you're done, make sure "Mute" 
is off for both tracks.  

7. Zooming In/Out on Tracks:  Notice that the first track is much shorter than 
the second track.  In order to work on the first track at a closer level, simply 

click on the track, and click the Zoom In (+) or Zoom Out (-) buttons. . 

Zoom until the top track occupies a bit more of the screen horizontally, as 
shown below: 

 
8. Using the Time Shift Tool: First, zoom out until you can see at least the 30 

seconds timeline in the screen. Click the Time Shift Tool . This tool allows 

you to change the relative positioning of tracks relative to one another in 
time. With the Time Shift Tool selected, you simply click in a track and drag 

it to the left or right.  Drag the top frame so it starts at the 6 second mark, as 
shown below. Once you are done, listen to the first 15 seconds again to see 

the result. 

  
9.  Fading In/Out with the Effects Menu:  Now you will modify the beam1 track 

(top track) so that awful sound at the end of the track fades out so that it is 

easier on the ears.  
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a. First zoom in on the track so that you can work with it easier (zoom so 
the top track almost fills the screen):  

 
b. Next, using the I beam (make sure you click on the I Beam), highlight 

the end of the top clip.  To fade the select from the menu, Effects > 

Fade Out and watch the highlighted section taper off. Now play the 

piece at that point.  

 
10. Next, you will be adding additional tracks. Import the following files in 

the order listed below, using File > Import > Audio... 
a. beam2.wav   (stereo) 

b. best.mp3   (mono) 
c. weeks.wav   (stereo) 

d. dah_duh_duh.mp3   (mono) 



 12 

 
11. To help get all the tracks on the same screen, you can adjust each track 

window just like in Windows. First, zoom until you can only see about 30 
seconds worth of audio. Then click on the dark grey area between two tracks 

and hold down your mouse button, and drag the window up to make it 
smaller (cursor should look as indicated below in red circle): 

  
 Repeat to make each track window smaller. 

12. Use the Time Shift tool to move each track so it is placed as in the 
picture below. Note you are moving each of the tracks to the 18 to 27 second 

range, with each track playing right after another (no overlaps). The 18 to 27 
second range is filled with an area of  “silence” in the background music, 

which will get filled by these tracks: 

 
13. Play the clip to make sure it works.  
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14. Exporting the new sound as an MP3 with attributes: Save the project again 

just to be on the safe side. 
a. From the menu select File>Export Audio…  Make sure Save as type: 

is MP3 Files and give the File name: mixing and hit the Save button. 
Then hit OK if prompted with “Your tracks will be missed down to 

two-stereo channels in the exported file.” 
b. Then when you get the Edit Metadata screen, put in the following 

information (but with your own name as the Artist)… This information 
will be shown in Windows Media Player, Realplayer:, and your browser 

later in this tutorial! 

 
15. Exit Audacity. Open the mixing.mp3 file in your lab10 folder and preview 

your track.  
16. In Windows Explorer, click on the View Tab and select Details and select Add 

Columns and make sure Contributing Artists and Album are selected and 
make sure they appear, should be similar to this: 
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Lab 10 - Tutorial 3 
 

Objectives: 
 

Upon completion of tutorial 3, you should be able to: 
 Insert an animated gif on a webpage. 

 Create a link inside a webpage that links to a sound file. 

 Insert the controls for a sound file, using a HTML audio tag, that play a sound 

when the user clicks on the controls. 

 Insert the controls for a video file, using the HTML video tag, that allows the 

user to play the video. 

 Create a link to a youtube video inside a webpage. 

 Fix a HTML video tag when the video file changes location. 

 Change the time at which the youtube video starts.  

 

SETTING UP THE WEB FOLDER IN KOMPOZER  
 

1. Open up KomoZer and create a site called Llamas and point it the folder 
called f:\\cs1033\lab10\llama  (or wherever your lab10\llama folder is 

located) 

 
2. In KompoZer, click on the + next to the images folder to expand it and see 

the files in that folder. 
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3. Click on the + next to the othermedia folder to 

expand it and see the files in that folder.  Notice 
that there is a file in this folder called 

llamasong.wav 
4. Open the webpage store.html by double 

clicking on it 
5. Highlight the words “Come and Get a Llama” 

and create a link to 
othermedia/llamasong.wav  

6. Save store.html  
 

 
 

 

OPENING THE WEBFILE IN A BROWSER AND FIXING A BROKEN LINK 
AND ADDING AN ANIMATED GIF 

 
7. Open Windows Explorer and find the lab10/llama folder 

 
8. Right click on the store.html  file and open it with Chrome 

 
 

9.  Click on the link you just created and make sure the sound file plays. Leave 

the Chrome browser open with your file loaded into it while you work on the 

file in KompoZer.  
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10. Go back into KompoZer, into the same file, store.html and find the 

part of the file that has XXX.  We are going to put another sound file here but 
this time it will have controls right in the webpage: 

a. Notice that in the images folder, we have a file called lovellama3.mp3 
b. Click on the Source tab at the bottom so that you can see the HTML 

tags 
c. Find the location where the XXX is and replace the XXX with the 

following HTML tags: 
  

  
 

d. Click on the Normal Tab along the bottom to see the page again and 
save the file. 

e. Refresh your Chrome browser to see the changes. Make sure there are 
controls for the audio file now and that it plays.  

f. The lovellama.mp3 file shouldn’t really be in the images folder, it 
should be in the othermedia folder.   Using Windows Explorer move 

the lovellama.mp3 file to the othermedia folder.  Notice that, in your 
webpage, your sound file no longer plays. This is because we have now 

broken the link.  Go back into the source code for the store.html file 
and figure out how to FIX this code (HINT: look at the src= part) so 

that the sound plays again: 

 
g. Save the file, refresh the Chrome browser, and make sure it works 

again.  
11. Now we are going to add the animated gif (petshopvideo.gif)we 

created in Lab 8 to the page. Notice this file is contained in the othermedia 

folder.  Go back to Normal mode (click on the Normal tab) in the store.html 
file. Put your cursor just after the table that holds your sound controls and hit 

enter a couple of times: 
12. From the menu bar select Insert>Image and put 

othermedia/petshopvideo.gif in the Image Location bar.  Put “Pet Shop” 
for the alternate text and hit OK.  

13. Save the file and refresh Chrome to make sure that it works.  
 

<audio controls="">  

<source src="images/lovellama.mp3" type="audio/mpeg"> 

Your browser does not support the audio element. 

</source> </audio> 

<audio controls="">  

<source src="images/lovellama.mp3" type="audio/mpeg"> 

Your browser does not support the audio element. 

</source> </audio> 
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ADDING A VIDEO AND A YOUTUBE CLIP TO A WEBPAGE 

 
14. Now we are going to add a video file to the wizards page. In KompoZer 

open the file called wizard.html 
15. In Windows Explorer, find the llama folder and right click on the 

wizard.html file and open it using Chrome and leave that open while you 
work on the file in KompoZer.  

16. Find where the XXX characters are located.  We are going to insert the 
movie clip into this location using the HTML video tags.   

17. Click on the Source tab along the bottom to see the HTML code.  
18. Find the location where the XXX is in the html code and replace it with 

the following: 

 
19. Change the part that is highlighted with ****  so that is points to the 

correct file (the file llamaplace.mp4 in the othermedia folder).  Look at the 

audio HTML tags if you need help figuring it out. Remember you will need to 
put where the file is located, remember the subfolder name and the file name 

and it has to be in quotes.   

20. Save the file 
21. Go back to Chrome and refresh the page and make sure that the movie 

clips plays properly.   
22. Now go back to KompoZer and go into source mode and find the 

<video> HTML tag area.  Right after controls=""   add with the following:  
poster="images/thewiz.jpg" so that it looks like this: 

 
23. Go back into Normal mode and save the file and go back to Chrome and 

watch what happens now. If you want an image to show up rather than just a 
black screen, you need to include: poster="filename.jpg"  

<video width="800" height="600" controls="">  

<source src="**** "  type="video/mp4"> 

Your browser does not support the video tag. 

</source> </video> 
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24. In Source mode, in the <video> tag, change the width="800" 

height="600" to width="200" height="100" and save the file and 
refresh in Chrome.  You can adjust the width and height of your video with 

these fields! 
25. Go back into KompoZer. Now we are going to add a youtube video to 

our page.  For a youtube video, you need to use the <iframe> HTML tag. Find 
the location where YYY is on the page. Click on the Source tab below to see 

the HTML tags and find the YYY in the code. Replace the YYY with the 
following (YOU MUST TYPE THE CASE EXACTLY AS BELOW!): 

 
26. Go back into Normal mode and save the file and go back to Chrome and 

refresh the page. Make sure the youtube video is playing.  

27. Go back into KompoZer and click on the Source tab to see the HTML 
and  find the <iframe> tag.  Then find the spot where it says:  

?start=67 
change that to: 

?start=407 
28. Go back into Normal mode, save the file and in Chrome, refresh and see 

if you can figure out what that did.  If you want to start at a particular 
location in the youtube video you need to add ?start=407 to the end of the 

file location (in this example ?start407 means start 407 seconds into the 

video).  
29. Close KompoZer. 

 
 

<iframe  

src="https://www.youtube.com/embed/ieFrIvFzJd8?start=67" 

height="315" width="420">  

</iframe> 
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Lab 10 - Tutorial 4 
 
Objectives: 

 
Upon completion of tutorial 4, you should be able to: 

 Upload the website you just created to a webserver. 

 Find the website on the internet and make sure it works. 

 
1. Run WinSCP (it should be an icon on the desktop or search for it using the 

search area in the bottom left corner). 
2. Fill in the WinSCP information as follows: 

a. Host Name: 
cs1033.gaul.csd.uwo.ca 

b. Port Number: 1033 

c. User Name: Your 

Western UserID 

d. Password: Your Western 

Password 
 

3. Click on the Login button. 

4. On the right side find your 
llama folder 

5. Drag the llama folder from the 
left side and drop it on the right side (but NOT inside one of the folders that is 

already there). 
6. Go into Chrome and make sure everything still works by going to: 

http://cs1033.gaul.csd.uwo.ca/~yourwesternid/llama  
7. Close WinSCP 

8. Show your Teaching Assistant your final website. 
9. Say goodbye to your teaching assistant as you have now officially 

finished all the CS1033 labs!  

 

 

http://cs1033.gaul.csd.uwo.ca/~yourwesternid/llama

